Jump to content

...What A Scary Day


Recommended Posts

Today has been a really interesting day, both at home and then at work.


I woke up this morning at 6:00 because I have to start getting ready for school, but I made the stupid mistake of going to bed at 3:00 am. So, I had 6 hours before I had to go to work, so I managed to make some Waffles with Vanilla Ice cream.


around 8:00 I became bored and decided to play some N64, namely Legend of Zelda OOT. So I plugged everything in, ploped the N64 ontop of my NES and tried booting it up... nothing... NOTHING! I started freaking out... OMG OMG My N64 is broken... then I realize that i forgot to plug it into the power bar... thank god it booted up (OOT = Ocarina of Time, which is FTW)


I played that for about an hour, then I decided to go back a few years and play the first Legend of Zelda... which didn't boot up, but that was typical of a 20+ year old game. So i tested out Duck Hunt, which didn't load, nor did SMB. So I made sure the console was plugged in, which it was, so I went and grabbed the Rubbing Alcohol and cleaned it... which didn't work. So I scrumaged through my house looking for a screwdriver to open my NES to clean the Pin-Connector. rehoocked it up, and still got that blinking screen of death. So i tried again and BOOM! I blew the upstairs fuse and lost power to everything.


So I went downstairs and fliped the switch and came upstairs. My TV would turn on, but the picture tube didn't engage. I'm like "Okay" so I try the N64... Nothing... the NES... Nothing, nothing from the DVD Player either... now I'm scared. Sooo then I walk over to my Dreamcast and hit the power button... the system powers on.. "Sweet fricken God, it works..." then it shut off... it just shut off.


Now i really, really started freaking out. My Laptop was still charging, and my printer was working but nothing else. I started to disconnect everything, not giving up that it didn't work. I re-connencted everything to the basement TV and then I heard the familar sound of the DreamCast! w00000t. My TV worked downstairs and everything else did. It seems that I had too many things running off the surge protector that it blew the fuse, but thankfully that powerbar absorbed the surge. I guess having the TV, Laptop, N64, and turning on the NES at the same was was not that smart of an Idea.


After all that running around, it was time to grab lunch and then head off to work.


When i got into my car, i noticed my brother had spilled Coke all over the cup holder, so I would have gotten that cleaned up at work.. as i'm back out onto the street and start readjusting the mirrors (while the car is in drive, and my foot on the brake) 2 wasps fly though the downed windows and fly near my hand. I freak out, and somehow slam the gas pedal and not realize it... until i'm on my lawn...


I arrive at work, and start early. I get into a car and BAM! I hit my ear/head on the top part of the car and fall out, while my good friend starts laughing at me. About 30 minutes later i get into a Van and hit my head on those stupid LCD screens for the DVD player and hear a snap. Never told anyone about it, but i think i broke one of the hinges. There was a nice Corvette Z06 that came in today, but with my stroke of accidents today, i decided to stay away from it. I also managed to cut my left hand ring finger when i was working with that same friend that laughed at me. She pointed out that there was blood over the hood of the car and all over my finger... !@#$


So that was my day, it got better near the end because it got really slow and gave my some time to sit back and relax... well maybe stand around and do squat.



So far, since i got home i've only managed to piss off my parents because they told me that they had ordered Pizza and I had go pick it up. I refused, but ended up doing it.



So My lesson learned? Get a good night's rest and this wont happen, lol.

Share this post

Link to post
Share on other sites

  • Create New...
[[Template core/front/_liskoduje/liskodujeJS is throwing an error. This theme may be out of date. Run the support tool in the AdminCP to restore the default theme.]]